


About Shareware distribution

This program    is NOT free or public domain software. This is SHAREWARE, i.e., copyrighted 
software which you can "try before you buy". If you try a Shareware program and continue 
using it, you are expected to register.Shareware is a distribution method, not a type of 
software. You should find software that suits your needs and pocketbook, whether it's 
commercial or Shareware. The Shareware system makes fitting your needs easier, because 
you can try before you buy. And because the overhead is low, prices are low also. Shareware
has the ultimate money-back guarantee -- if you don't use the product, you don't pay for it.

So, What is the difference between the Registered and Unregistered versions?
Functionally there is no difference - it's the same program with the same features. Just one 
thing - you can't use the unregistered version forever.    The evaluation version allows you to 
execute the program only 100 times. After that you will not be able to use the software. If 
you like the program and want to continue using it you are required to register.

 



ASP Ombudsman statement

    This program is produced by a member of the Association of Shareware Professionals 
(ASP). ASP wants to make sure that the shareware principle works for you. If you are unable 
to resolve a shareware-related problem with an ASP member by contacting the member 
directly, ASP may be able to help. The ASP Ombudsman can help you resolve a dispute or 
problem with an ASP member, but does not provide technical support for members' 
products. 
Please write to the :

ASP Ombudsman at 545 Grover Road,    
Muskegon, MI 49442-9427 USA, 
FAX 616-788-2765 

or send a CompuServe message via CompuServe Mail to :
ASP Ombudsman 70007,3536.              

 



Auto-Walk Mode

      Auto-Walk mode allows you to speed up the merging process by automatic advancing the 
merged files. Each time you select a colored segment the program will jump to the next 
section saving you from manual scrolling. 



Command line

      Certain options can be specified in the command line upon the program start. This 
feature allows for greater flexibility and speeds up the process of merging. Here is the list of 
options which can be specified in the command line:
· -d1 <dir name>

Starting directory for the left file open dialog (overrides INI file settings)

· -d2 <dir name>
Starting directory for the right file open dialog (overrides INI file settings)

· -f1 <file name>
Loads file <file name> into the left window. If the file name does not contain the full path
it would be searched    in the following places: 

current directory
the directory specified by -d1 option (or the directory specified in the INI file if -d1 
option is not present).

· -f2 <file name>
Loads file <file name> into the right window. If the file name does not contain the full 
path it would be first searched    in the current directory, then in the directory specified 
by -d2 option (or in the directory specified in the INI file if -d2 option is not present).

If both -f1 and -f2 are specified the files will be compared automatically right after being 
loaded.

· -outf <file name>
Output results to file <file name>

· -outd <dir name>
Use <dir name> as default output directory name

Command line usage example:

            vmerge -d1 c:\temp -f1 file1.txt -f2 c:\misc\file2.txt

            Loads files c:\temp\file1.txt and c:\misc\file2.txt and compares them.
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context lines

context lines are lines that precede a differing segment 



Customizing directory comparison

        By default Directory Compare algorithm merges everything in the source directories. In 
some cases, however you may prefer to ignore some types of files (like *.bak, for example) 
or compare only certain types (only *.c, for instance). You can do this by specifying Include 
or Exclude filters for Directory compare. If you specify at least one include filter than only 
files matching some pattern in the Include box will be compared. Note that any file matching
some pattern in the exclude box will be ignored, even if it matches Include filters.



Customizing File Filters

      You can add your own File Types to Open file dialog. Select Options->File filtering->File 
types and add file filter and description of the type. You you want to add a multiple wildcards
filter you should separate wildcards with semicolon. For example:
            File type: *.c;*.h
            Description: C files
To delete a file type open File Types dialog, select the type from the list and press Delete 
button.



Customizing fonts

        You can separately select fonts for file panes and for file name labels by selecting 
Options->Fonts->Text or Options->Fonts->Title menus.



Distribution terms
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File menu commands

File menu items depend on the current working mode. If you are comparing files (normal 
mode) File menu will contain the following entries:
· File 1 - for choosing the first file name
· File 2 - for choosing the second file name
· Compare dirs      - compares two directories (see also Merge directories)
· Compare files    - compares two files (see also Merge files)
· Write    - writes the results
· Print    - prints the combined version
· Quit      - just this.

However, in directory comparison mode this menu will have different contents:
· Skip          - skip current file and continue comparing
· Cancel - stops directory comparison and returns to the normal mode
· Write    - writes the results and proceeds to the next file
· Print    - prints the combined version
· Quit      - just this.
 



Find differences

To calculate and display differences between two files you should perform following steps:
      
·         Open files to be merged by selecting File->Open menu or by dragging them from File 

Manager . The files will be displayed in file panes. VMerge will enumerate file lines if 
"Line Numbers" option is checked.

·         Select Compare Files from File menu or press Ctrl+D. The program will calculate the 
differences and color the differing sections of both files in two colors - green and yellow. 
Yellow lines are blank lines that have to be added to the file to match the segment in the 
second file. Lines are colored green if the matching lines of the second file either differ or
are missing at all (in the last case lines of the second file are yellow). Vmerge shows you 
the relative positions of the differing segments in the Position Bar

At this stage you may proceed to resolving differences between your files (see Merge files)



General options

      General options dialog includes the following elements:
    ·  Tab size - the number of spaces represented by tab character. This attribute influences 

only the display. When you write an output files VMERGE will preserve real tab 
characters.

· Context lines - the number of context lines. If this field is zero, VMERGE will display the 
section right at the top.

· Display line numbers - for each line display its number in the original file.

· Synchronized scrolling - Synchronizes horizontal scrolling in both file panes.

· Auto-Walk - Toggles the Auto-Walk Mode.

· Compress spaces - instructs to consider a sequence of white spaces as a single space.

· Unix file format - The output file will be written in the UNIX file format(each line is 
terminated only by end-of-line character).

You can access these options by choosing Options->General menu.



How to Register?

      There are three types of licences: single-user, site and world-wide. Single user licence 
limits the usage of the program to a single computer at any given time. Site licenses 
cover a single organization for an area of up to one hundred miles (160 km) in radius. A 
world-wide license covers everyone in a single organization. Please observe and verify 
the total of your payment as you select licenses.

          The license fee may be paid by check, money order, cash, VISA, MasterCard, American 
Express, Discover, Diners Club or First Virtual.

          There are 4 ways of registering VMERGE:
    1.  Run REGISTER.EXE provided with the program. If you did not receive it in your 

package please contact the author. REGISTER.EXE will help you to fill the order form 
which should be faxed or e-mailed to Kagi Shareware. REGISTER.EXE comes with online 
help explaining the registration procedure in details. If you have any problem with 
registering the product don't hesitate to contact Kagi:

via Mail: admin@kagi.com
via WWW:    www.kagi.com
via Fax:    +1 (510) 652-6589
via Phone: +1 (510) 601-5244
via Postal Mail:

Kagi Shareware
1442-A Walnut Street #392
Berkeley California 94709-1405
USA

Note that Kagi is only a processing service so any questions related to the product itself 
should be directed to the author.

2.  You can register VMERGE using Kagi's online order processing system. Just browse to
http://order.kagi.com/cgi-bin/register1.cgi?VI or
https://order.kagi.com/cgi-bin/register1.cgi?VI (secure)

and fill the order. 

3. You may register via telephone. Call these numbers and place your order:
+1 (510) 658-5244
+1 (510) 601-5244

NOTE: you will be charged additional 5$ if you order by phone.

4.  You may send the payment directly to the author(see the form below). In this case, 
however, you may pay only by check.

      The program may be delivered by e-mail or by snail mail. In the latter case you 
should add a postal fee.
      Please check your delivery address.

IMPORTANT:  As a registered user you will receive the latest version of the program and 
future releases.

The following information regards only users wishing to register directly with the author. 
Please fill the form below, attach a check in US dollars payable to Olga or Victor 
Golosovker and send it to the following address:
      Mr. V.Golosovker,
      16/10 Havacelet,



      Nesher,
      Israel 36731.

=============        ORDER          FORM      ==========================

Name: _____________________________________________________

Company: __________________________________________________

Address: ___________________________________________________

__________________________________________________________

Tel/Fax: ___________________________________________________

    Please accept this registration fee for VMERGE v1.30.

    Please send me (check the box) :

    [ ]    Diskette with the program by mail.
[ ] Please, send me 3 1/2" diskette
[ ] Please, send me 5 1/4" diskette

    [ ]    The program by e-mail (address attached).
                Internet E-mail:    ______________________________

    ________________________________________          _______________
SIGNED                                                                              DATE

    Registration fee:

      Single-user licence :    $ 25.00 _____
      Site                licence :                          $ 200.00    _____
      World-wide    licence :    $ 2000.00 _____

    Postal fee (if applicable):        $10    _____

TOTAL            $ _______

============== END    ORDER      FORM      ==========================



Keyboard

·           Ctrl+F1 - load left file
·           Ctrl+F2 - load right file
·           Ctrl+O    - compare directories
·           Ctrl+D    - display files differences
·           Ctrl+W    - write out the results.
·           Ctrl+N      - Next differing section
·           Ctrl+P      - Previous differing section
·           Ctrl+F      - Font selection box
·           Ctrl+T    - Tab size selection
·           PgDown    - Next screen
·           PgUp        - Previous screen
·           Ctrl+PgDown    - Jump to the file end
·           Ctrl+PgUp        - Jump to the file beginning
·           Alt+S      - Skip to the next file (directory comparison)
·           Alt+C      - Cancel directory comparison.

          



License agreement

 TRIAL USE LICENSE

      VMERGE is NOT a public domain program.    It is copyrighted by
      Victor Golosovker.    This software and accompanying documentation are
      protected by United States copyright law and also by international
      treaty provisions.

      Victor Golosovker grants you a limited license to use this software
      for evaluation purposes for a period not to exceed 100 program
      executions. If you continue using this software after the
      evaluation period, you MUST make a registration payment to Victor
      Golosovker.

      You may not use, copy, rent, lease, sell, modify, decompile,
      disassemble, otherwise reverse engineer, or transfer the licensed
      program except as provided in this agreement.    Any such unauthorized
      use shall result in immediate and automatic termination of this license.
      All rights not expressly granted here are reserved to Victor Golosovker.

LIMITED DISTRIBUTION LICENSE

      Permission is granted to individuals charging no fees, and to BBSs,
      User Groups, Mail-Order Disk Vendors, CD-ROM publishers, and BBS
      File-Distribution Networks regardless of fees, to distribute
      VMERGE , provided they convey a complete and unaltered copy of
      the shareware version of this product, and provided they claim no
      ownership of these products.

      Distribution by other channels, and distribution of modified versions,
      are also allowed, but only under the terms of the attached VMERGE data
      record, which is hereby incorporated by reference. Any distribution
      satisfying all the distribution requirements expressed in that data
      record is hereby authorized.

      Permission to distribute the VMerge package is not transferable,
      assignable, saleable, or franchisable.    Each vendor wishing to
      distribute the package must independently satisfy the terms of this
      limited distribution license.

      U.S. Government Information:    Use, duplication, or disclosure by the
      U.S. Government of the computer software and documentation in this
      package shall be subject to the restricted rights applicable to
      commercial computer software as set forth in subdivision (b)(3)(ii) of
      the Rights in Technical Data and Computer Software clause at
      252.227-7013 (DFARS 52.227-7013).    The Contractor/manufacturer is
      Victor Golosovker, Havacelet 16/10, Nesher, Israel 36731.

      Victor Golosovker may revoke any permissions granted here, by
      notifying you in writing.    All rights not expressly granted here are
      reserved to Victor Golosovker.



LIMITED WARRANTY

      THIS SOFTWARE AND MANUAL ARE PROVIDED FOR EVALUATION ONLY, ON AN "AS
      IS" BASIS.    THE AUTHOR DISCLAIMS ALL WARRANTIES RELATING
      TO THIS SOFTWARE, WHETHER EXPRESSED    OR IMPLIED, INCLUDING BUT NOT
      LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR
      A PARTICULAR PURPOSE. NEITHER THE AUTHOR NOR ANYONE ELSE
      WHO HAS BEEN INVOLVED IN THE CREATION, PRODUCTION, OR DELIVERY OF
      THIS SOFTWARE SHALL BE LIABLE FOR ANY INDIRECT, CONSEQUENTIAL, OR
      INCIDENTAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE SUCH
      SOFTWARE, EVEN IF THE AUTHOR HAS BEEN ADVISED OF THE
      POSSIBILITY OF SUCH DAMAGES OR CLAIMS.    THE PERSON USING THE SOFTWARE
      BEARS ALL RISK AS TO THE QUALITY AND PERFORMANCE OF THE SOFTWARE.

      This agreement shall be governed by the laws of the State of Israel
      and shall inure to the benefit of the author and any
      successors, administrators, heirs and assigns. Any action or proceeding
      brought by either party against the other arising out of or related to
      this agreement shall be brought only in FEDERAL COURT of
      competent jurisdiction located in Israel. The parties
      hereby consent to in personam jurisdiction of said courts.



Merge directories

      Select "Compare Directories" in File menu. Vmerge will prompt you for first, second and 
target directories. The program will compare the files in the first directory against the 
second directory.    
If the same version of a file is present in both places or file with a certain name is found only
in one directory, the program will copy it to the destination directory. If two files with the 
same name but different contents are present in compared directories, they will be 
displayed side by side just as if you were comparing files in normal mode. The only 
difference is the changed File menu.              
To proceed without merging the current file you should select Skip in the File menu. 
If you want to stop comparing the directories you should choose Cancel.
To merge the current file you should resolve all the differences and write the result to the 
disk (see Merge files section). After saving the merged version the program will proceed to 
the next file.
By default VMERGE compares everything in the specified directories. However you can 
customize this behavior by specifying exclude and include filters. When you add an exclude 
filter all files matching this filter will be ignored. If you specify at least one include filter, only
the files matching include filters will be compared. If a file matches both exclude filters and 
include filters it will be ignored.

Note : Although VMERGE    preserves the older version of output file you are strongly 
advised to create backups for directories you intend to change.

See also:

Customizing directory comparison

 



Merge files

To combine two files you will first have to Find differences. The program will display all 
differing segments side by side. For each of these sections you will have to select either left 
or right version by clicking left mouse button over the colored text. Selected segments will 
change their color to blue. After having resolved all the file differences you will be able to 
save or print the resulting version. 

Note :        If the file already exists it will be overridden. The original file will be saved under 
the name <name>.bak to prevent data loss. 

See also: 

Search menu commands

 



Options menu commands

·                   General options
·                   Fonts - allows you to select fonts (see Customizing directory comparison)
·                   File filtering - see Customizing File Filters
 



Position Bar

      Vmerge allows you to see the relative positions of the differing segments all at once. Each
segment is represented by a mark in the Position Bar (two columns around the vertical 
scrollbar in the center). You can quickly scroll the file pane to a certain segment by simply 
positioning the scrollbar against the appropriate mark.



Search menu commands

·                 Next            - go to the next differing segment
·                   Previous    - go to the previous differing segment
·                 Next Unresolved          - go to the next unresolved differing segment
·                   Previous Unresolved    - go to the previous unresolved differing segment
·                   First          - go to the first differing segment
·                   Last            - go to the last differing segment
·                   Beginning - go to the first line of the file
·                   End              - go to the last line of the file

You can instruct VMERGE to show a number of context lines before the segment when you 
jump to it. For more detailed instructions see General options.
 



Select menu commands

·                   From Left        - chooses all the unresolved differences from the left file
·                   From Right      - unresolved segments are taken from the right file
·                   Unselect All - dismiss all the choices made so far 



Technical support

      Technical support will be available via mail or e-mail for registered users only. User who 
submits a bug report(including all needed accompanying files and procedures to reproduce 
the bug) during the first 90 days after his registration will receive a satisfying solution to the 
problem or full refund of the registration fee. Beyond the 90 days period the author is not 
obligated to refund the user, though the best efforts will be made to fix reported bugs. To get
the support please contact the author:

      By e-mail:
            victor@kagi.com                  or
            victor@harmonic.co.il

      By mail:
            Olga or Victor Golosovker,
            16/10 Havacelet,
            Nesher,
            Israel 36731.
 
      You are invited to visit product's homepage:
            http://members.tripod.com/~olgac/products.html



What is new in this version(since version 1.27)?

· Recursive directory comparison feature added

· Jump to the next/previous unresolved segment

· Displaying differing segments in their context

· Synchronized horizontal scrolling

· Unix output file format

· Customization of file types in the "Open file" dialog

· Include / Exclude filters for directory comparison.

· Last run position and size are remembered

· Drag and drop support added

· Toolbar added in 32 bit version

· Cancel directory comparison feature added

 



What is Visual Merge?

        VMERGE is an easy to use program designed to help people in merging files. Those who 
have tried once to combine two similar versions of a program know how difficult it is. There 
are always some lines which get forgotten or misplaced. 
        There are some utilities for comparing files and producing list of differences between 
them, but these programs will often scarcely help, because one should still perform merging 
manually, cutting lines alternately from both of the files. On the other hand, there are 
programs that can create a third file based on two version, but they are either too primitive 
or too complex for everyday use. 
      VMERGE makes file merging much easier by letting you to choose between the differing 
segments by a single mouse click. Its intuitive interface and other features allow you to 
minimize manual postprocessing thus saving your time.
      The program comes in two versions - 16 bit and 32 bit. The former is limited to files 
shorter than 64 K, while the latter imposes no size limits, supports long file names and may 
be run on Windows NT, Windows 95 or Windows 3.1 with Win32s installed (Win32s is freely 
distributed by Microsoft and may be downloaded from ftp.microsoft.com).

 Visual Merge is not a FreeWare nor a Public Domain. 
 VMERGE    is ShareWare, copyright (c) 1994-1997    by Olga and Victor Golosovker. 
Please, support the ShareWare concept and register your copy
      
 The author will be thankful for any comments, suggestions and bug reports.
 




